This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: fresh perlbuild and cygwin-snapshot

Earnie Boyd schrieb am 2001-09-06, 13:31:

>"Gerrit P. Haase" wrote:
>> Charles Wilson schrieb am 2001-09-06, 10:58:
>> >Gerrit P. Haase wrote:
>> >
>> >
>> >> I tried a second with the latest snapshot (2001-09-04), same result. I
>> >> reinstalled 1.3.2 and now it works as before, no idea what is going on.
>> >
>> >Note that "official" package releases *must* be built only on systems
>> >that do not have any snapshots or unreleased versions of dependencies.
>> >That is, build your perl against a snapshot if you want, but don't
>> >release it to sourceware unless you rebuild against 1.3.2 or 1.3.3. Ditto
>> >"unreleased" versions of dependencies like zlib or readline or whatever.
>> [...]
>> Thanks for the hints.  I hope it will not happen to me.
>> I just wanted to try out if there are some obvious differences, but there
>> are no differences besides the fact that no functions were found and they
>> didn't work for perl like ( time() ) which results in a compiletime error.
>Remember, you must also install the headers and libs in the cygwin-inst for
>the snapshot when building afresh with a new dll.  You may need to even
>rebuild the dependant object libraries, but that isn't always the case. 
>Cygwin1.dll remains binary executable backward compatible but not
>necessarily binary object backward compatible.

Ah, that means it may be neccessary to rebuild gdbm.dll and zlib.dll?
But the errors I got were with a complete install of the snapshot including
/usr/lib/... and /usr/include/... files and Configure wasn't able to find functions like e.g. time() which are in cygwin1.dll. 
Now i saw that in the snapshot libc.a is no symlink to libcygwin.a.
Perl thinks it links against libc.a, so it will 'look only' and 'not find them' in libc.a if they are only defined in libcygwin.a.
But I wondered that at compiletime (runtime?) the functions were also failing.
Now i will try again with linking libc to libcygwin, that should work better (I hope so).



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]