This is the mail archive of the
mailing list for the Cygwin project.
Package naming convention and contents
- From: David Stacey <drstacey at tiscali dot co dot uk>
- To: cygwin-apps <cygwin-apps at cygwin dot com>
- Date: Mon, 08 Jul 2013 20:06:26 +0100
- Subject: Package naming convention and contents
I am preparing a library package called Poco. Whilst Marco gave me a
GTG, both he and Ken were a little unsure about the package names that I
had used. Please could some of you good folk give me a little guidance
in this matter.
At the moment, I have tried to copy the naming convention used by our
'boost' package, as Poco is similar in its layout and intended usage. I
have a source package (poco-1.4.6p1-1.src.tar.bz2) that builds the
- Several versioned libraries, e.g. cygPocoData_1_4_6.dll.
- A couple of unversioned executables.
- Header files and libs to link against Poco.
- HTML documentation.
- Debug files, generated by cygport.
The contentious package is the first one. The point of having versioned
library files is that you can have any number of them installed
side-by-side (if you'll forgive the Microsoftism). In that way, some
other package will always pull in the exact version of Poco that it was
linked against. For that reason, the two unversioned executables don't
belong here, and I should probably move them into a package simply
called 'poco'. However, unless there's an API breakage, versioned
libraries shouldn't be necessary.
Then there's the name of the package itself. This could have been
'libpoco', 'libpoco1', or 'libpoco1.4'. The first of these is probably
wrong, as there is some intention to release Poco 2.x at some point that
will require a C++11 compliant compiler. Hence, we'll may want to
support Poco 1.x for a while. Reading the change log, it appears that
API changes can come in at any release.
So please could you advise on whether you think 'libpoco1.4.6' is a
sensible name, or suggest an alternative if it is not to your taste.
Also, should this package contain versioned libraries (of the form
'cygPocoData_1_4_6.dll') or should the version number be stripped
I have to re-package this anyway (as an errant hyphen slipped its way
into a package name), so whilst I'm doing that I want to make sure it's
packaged in a way that everyone is happy with.
Many thanks in advance,
PS: Apologies if this thread really belongs on the main cygwin list.
I've submitted it to cygwin-apps as it is a packaging question.