This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Openbox gray screen

Hi All,
Problem: Opening CygwinX with Openbox and getting a window with gray
screen background. Like this: grayscreen.GIF
Part(1) My installation steps:
* Downloaded CygwinX setup.exe.
* Invoked exe and installed default packages.
* I then invoked the exe again and selected ALL modules under X11R
* I opened C:\Cygwin\usr\X11R6\bin\startxwin.bat and inserted REM in
front of all the %RUN% statements, this is comment them out.
* I then inserted two new statements at the end of the bat file like so:
        run XWin
        run openbox
* I invoke the bat file and get the gray screen attached.
* Please see Part(1) logs below.
Part(2) But the funny thing is:
* When I get the gray window and invoke the startxwin.bat again (whilst
the first X server is already running).
* I get an error message like this: cygwerror.GIF.
* When I ok and close the error box.
* The first window that was gray is now showing the Openbox GUI
correctly like this openbox.GIF
* Please see Part(2) logs below.
The question is why am I getting the gray screen?
Any help or tips will be appreciated thanks.
* From Part(1)
    Welcome to the XWin X Server
    Vendor: The Cygwin/X Project
    _XSERVTransmkdir: ERROR: euid != 0,directory /tmp/.X11-unix will not
be created.
    XWin was started with the following command line:
(II) XF86Config is not supported
(II) See for more information winCreateBoundingWindowWindowed - Setting
normal windowstyle MIT-SHM extension disabled due to lack of kernel
support XFree86-Bigfont extension local-client optimization disabled due
to lack of shared memory support in the kernel
(--) Setting autorepeat to delay=500, rate=31
(--) winConfigKeyboard - Layout: "00000809" (00000809)
(--) Using preset keyboard for "English (United Kingdom)" (809), type
(--) 3 mouse buttons found
Could not init font path element /usr/X11R6/lib/X11/fonts/CID/, removing
from list!

* From Part(2)
Welcome to the XWin X Server
Vendor: The Cygwin/X Project
_XSERVTransSocketINETCreateListener: ...SocketCreateListener() failed
_XSERVTransMakeAllCOTSServerListeners: server already running
Fatal server error:
Cannot establish any listening sockets - Make sure an X server isn't
already running winDeinitMultiWindowWM - Noting shutdown in progress
winProcEstablishConnection - Clipboard is not enabled, returning.

The information contained in this email is strictly confidential and for the use of the addressee only, unless otherwise indicated. If you are not the intended recipient, please do not read, copy, use or disclose to others this message or any attachment. Please also notify the sender by replying to this email or by telephone +44 (0)20 7896 0011 and then delete the email and any copies of it. Opinions, conclusions (etc.) that do not relate to the official business of this company shall be understood as neither given nor endorsed by it. IG Markets Limited and IG Index Plc are authorised and regulated by the Financial Services Authority and, in Australia, by the Australian Securities and Investments Commission.

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]