This is the mail archive of the cygwin-xfree mailing list for the Cygwin XFree86 project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: 64-bit Clipboard troubles

On 09/06/2013 19:59, David Stacey wrote:
> I am trying to package keepassx for 64-bit Cygwin, and have noticed a 
> difference between the way the clipboard functions under 32-bit and 64-bit 
> Cygwin/X. Essentially, keepassx is an encrypted password database that
> copies your username and password to the clipboard. Then, you can paste
> these into a web site (say) to log in.
> When I run keepassx (both 32-bit and 64-bit builds) using the 32-bit
> version of XWin, keepassx copies the username and password to the
> clipboard, and these can be pasted into a native Windows web browser (e.g.
> Firefox). However, when I run keepassx (again, both 32-bit and 64-bit
> builds) using the 64-bit version of XWin, the procedure breaks: I instruct
> keepassx to copy to the clipboard, but when I paste in the web browser, no
> text is pasted.

Sorry, integration between the native and X clipboards is broken in 64-bit XWin.

Unfortunately, this is rather complex to fix and I haven't found the time to
do so yet.

> I mentioned that my testcase programme doesn't quite work as I intended:
> writing to the clipboard using Qt4 and reading it back by reading
> /dev/clipboard fails when using both 32-bit and 64-bit XWin. I don't
> understand why, but this is probably down to my own limited understanding
> of the clipboard in X.

Thanks for writing this useful testcase.

>From a brief glance, the test looks well formed, so I'll also try to take a
look at why test 2 always fails, I guess this indicates some bug in the
clipboard integration.

Volunteer Cygwin/X X Server maintainer

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]