This is the mail archive of the mailing list for the Cygwin project. See the Cygwin home page for more information.
[Date Prev][Date Next][Thread Prev][Thread Next]
[Date Index] [Subject Index] [Author Index] [Thread Index]

RE: troubles while building wxWindows/C++ Mingw executables usin

On Wed, 10 Mar 1999, Vadim Zeitlin wrote:

>  There is no reason it shouldn't be possible. It would be interesting
> to hear whether you succeed with it finally and what had you to change
> to do it.

It does work quite well, except for a few gotcha's:
  - you need the mingw version of _G_config.h, which is installed when
    you install the C++ runtime library. Unfortunately, my extra
    mingw libraries package for cygwin doesn't have it (oversight).

  - you have to make sure that *every* compile/link command uses the
    -mno-cygwin flag.

    Also, you *must* have mingw version of libm.a ... this is part of
    egcs-1.1.1-mingw-libs.tar.gz that I distribute.

  - need to fix the libraries that wxwin links in by default.
    Specifically, I believe you need to delete -loldnames, which should
    not have been there in the first place.

    I simply used "c++" as the driver (wxwin uses gcc) to avoid specifying
    -lstdc++ explicitly, and also specified the following in
      CC = c++ -mno-cygwin
      OPTIONS= -D__EGCS__  -mno-cygwin #-D__MINGW32__
      WINLIBS= -lwinspool -lwinmm -lcomctl32 -lctl3d32 -lodbc32
    (note: I may have missed one or two win32 specific import libraries
    in WINLIBS, but most of the samples did build fine using above).

Since it works for me, it should work for others as well, especially given
that the machine I tested this on doesn't have anything different/special.

I hope Christine Pourcelot posts her experience here once she has things 
squared away.

This is of course for building mingw wxwin using Cygwin gcc; for native
Cygwin builds, it all works out of the box.

I will add this info to my howto on using -mno-cygwin ...


Want to unsubscribe from this list?
Send a message to