This is the mail archive of the mailing list for the Cygwin project. See the Cygwin home page for more information.
Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: problem building egcs-1.1.2

I seem to have been successful. I got the source from and
Mumit's patches from
I extracted egcs-1.1.2-x86-win32.diff from the patch file, and applied it
successfully to the source distribution.

My cygwin configuration is not "standard". In retrospec, this is probably an
error, but I made my NT box look like the Unix boxes that I use; I find it
easier to remember where given files are if they are always in the same place on
each box. Specifically, I have my executables in /usr/local/bin, and the headers
and libraries in /usr/local/i586-cygwin32/...

The default target for egcs-1.1.2 under cygwin is i686-pc-cygwin32. I duplicated
the /usr/local/i586-cygwin32 directory as /usr/local/i686-pc-cygwin32. I then
created a separate build directory, cd'ed into it, and did:

../egcs-1.1.2/configure --with-local-prefix=/usr/local/i686-pc-cygwin32
make bootstrap
make install

The compiler used initially was egcs-1.1.1, not egcs-1.1b. Other than that, my
setup is the same as yours: NT4SP3, cygwin b20.1. uname -m report i686 rather
than i586 (probably not relevant).

I am now running the regression test suite. I took me a while to figure out why
all execution tests fail under cygwin. There is a problem in the expect
interpreter: it does not understand Unix-style absolute path names (e.g.
/home/gauthier/build-egcs/gcc/testsuite/900409-1.x0). I had to modify the
generated site.exp file to use either relative pathnames, or add leading drive
letters to the pathnames (I have D: mounted as /home, so I specify paths as

The dejagnu framework appears to be very unstable under cygwin. During execute
tests, I appear to get SEGV signals at random. I just don't trust the test
results; every test passes until a SEGV stops the testing of a given suite.

Also, I gave up on the initial tests in /build-egcs/i686-pc-cygwin32/libio/dbz.
Too many problems... wrote:

> I've been trying to build the egcs-1.1.2 binaries with
> Mumit's patches applied to the source, but have so far been
> unsuccessful.  The steps I've taken are summarized in
> the short script appended to the end of this note (my
> cygwin package is installed in the `standard' place,
> ie, C:\cygnus\cygwin-b20).
> Following these steps (after an hour or so...) the build
> ends in `Bootstrap comparison failure!', with *lots* of
> lines like:
> alias.o differs
> bitmap.o differs
> c-aux-info.o differs
> c-common.o differs
> c-decl.o differs
> ...
> The various environment variables (C_INCLUDE_PATH, etc)
> have been set more-or-less on a trial and error basis
> to eliminate errors at earlier stages in the build.
> Perhaps they're wrong, or perhaps I'm missing some...
> I'm running NT4/sp3, with cygwin b20.1.  My DLL version
> (from uname -a) is:
> CYGWIN_NT-4.0 SUSY 20.1 (0.3/1/1) 1998-12-3 20:39:18 i586 unknown
> Has anyone else attempted building egcs-1.1.2 with
> Mumit's patches, and with what success?  I'm sure
> that my problems stem from my implemtation rather
> than from the patches.  Any feedback or suggestions
> would be appreciated.
> cheers, Paul
> #
> ######
> #
> #!/bin/bash
> CYGTOP=/cygnus/cygwin-b20/H-i586-cygwin32/i586-cygwin32
> export C_INCLUDE_PATH=$CYGTOP/include
> export OBJC_INCLUDE_PATH=$CYGTOP/include
> tar -zxvf egcs-1.1.2.tar.gz
> tar -zxvf egcs-1.1.2-x86-win32-patches.tar.gz
> patch -p0 < egcs-1.1.2-x86-win32.diff
> mkdir egcs-obj
> cd egcs-obj
> ../egcs-1.1.2/configure \
>   --prefix=/usr/local/package/egcs/1.1.2 \
>   i586-cygwin32
> make bootstrap-lean
> #
> ######
> #
> ---------------------------------------------------
>    Paul Poffenberger          phone (250) 721 7741
>    Dept of Physics            fax   (250) 721 7752
>    University of Victoria     email
> ---------------------------------------------------
> --
> Want to unsubscribe from this list?
> Send a message to

Charles-Antoine Gauthier
Research Officer
Software Engineering Group
Institute for Information Technology
National Research Council of Canada
Ottawa, ON, Canada
K1A 0R6

Want to unsubscribe from this list?
Send a message to