This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

bash, background java VMs and ctrl-C

I have a difficult time with the following bash (or maybe cygwin.dll)
	bash-2.05a$> java com.edgility.<blah>.ClassName &
	bash-2.05a$> tail -f mylogfile

as soon as I hit ctrl-C the java VM exits.

In the bash reference manual it talks about background processes being
in different process groups and not propagating a SIGINT to those

I read through every option available to stty and tried various ones
that sounded related with no effect. I have also tried starting the VM
with: (trap "" 1 2 3; java com.edgility.<blah>.Classname &) also with no

Further, I read a lot in the mail archive for this group about bash vs.
cmd and the difference between ctrl-C and ctrl-break and how cygwin.dll
handles interrupts. It looks like a change went into 1.3.7 controlling
how signals are propagated, but I wasn't clear on exactly what effect
the change had. I was running 1.3.6 and upgraded to 1.3.9 and the
behavior is exactly the same in both cases for me. What is absolutely
baffling is that a co-worker is also running 1.3.9 and the same version
of bash and he does not see this behavior.

All of this leaves me wondering, 1. what is supposed to happen to
background processes in bash when one types the interrupt character? 2.
is there some configuration option that affects this?

Any insights (penetrating or otherwise) would be appreciated,
jeff meredith (

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]