This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

install process hangs on when run under windows 98 (using setup v2.249.2.4)

I have tried several times to install Cygwin using the setup.exe from the
cygwin homepage on my PC which is running Windows 98 second addition each
time with the same result.

All goes well selecting install options - defaults for everything up to
download location (I have tried all UK ones)

I select which packages I want (I have tried leaving at defaults and
clicking next, selecting just cygwin DLL - v 1.3.11-3, selecting in addition
to defaults what I actually want - xfree, man and file packages)

Download runs along ok

When download completes I select tick box to create start menu icon rather
desktop icon.

Lots of DOS boxes then appear and disappear as various post setup actions
take place. The last box to appear displays commands mkpasswd and then
mkgroup being executed and directing their output to /etc/passwd and group.
The PC then stops responding to anything and the last DOS box remains on the
screen (even after leaving PC thinking for over 5 minutes) other than mouse
pointer movement (keyboard - other than CTRL-ALT-DEL - and mouse clicks do
not give feedback) and CTRL-ALT-DEL.

CTRL-ALT-DEL when pressed brings up close program dialogue box in which
MS-DOS prompt is said to have stopped responding also shutdown option is
grey-ed out.

If a close this program the PC still doesn't come back to life and I have to
reset the system using the reset button on the base unit.

I delete the c:\cygwin directory and the directory the internet download
places files in and remove the registry key tree "Cygnus Solutions" from
HKEY_LOCAL_MACHINE/Software and HKEY_CURRENT_USER/Sofware between attempts
to install to ensure the system is clean as far as Cygwin setup is

I have tried just downloading the packages using the option to do so in
setup and then running the install from a local directory - this has the
same result.

Can anyone suggest what is going wrong and how to sort things out ?



Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]