This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Available for test: gcc-3.1.1-2 gcc2-2.95.3-8

Christopher Faylor wrote:

On Thu, Jul 11, 2002 at 01:19:03PM -0400, Charles Wilson wrote:

attempt to open /usr/lib/mingw/libstdc++-2.a succeeded

This is suspicious.  It almost looks like libstdc++-2.a is empty.
Otherwise, you would have seen some symbols being loaded here.

I just tried this with the copy of libstdc++-2.a that I'd been
using for setup builds and it seems to work ok.

Could you do a "nm" on this file and make sure that it is not
corrupted?  Or maybe you need to do a ranlib on it?

It had symbols.

I've put the copy of libstdc++-2.a that I'm using at

if you want to try it.


gcc-3.1.1 (or maybe gcc-mingw-3_1-20020516-1) clobbered my old gcc-2.95.3 (mingw) version of /usr/lib/mingw/libstdc++.a.

I copied it to libstdc++-2.a AFTER installing gcc-3.1.1. After restoring my original file (to libstdc++-2.a), everything worked.

Sorry for the confusion (boy, I feel silly).



gcc works
gcc -mno-cygwin works
g++ works
g++ -mno-cygwin works
g77 works
g77 -mno-cygwin works


gcc-2 works
gcc-2 -mno-cygwin works

g++-2 works
g++-2 -mno-cygwin works (provided one installs libstdc++.a from mingw's gcc as /usr/lib/mingw/libstdc++-2.a)

g77-2 breaks:
/usr/lib/libcygwin.a(libcmain.o)(.text+0x81): undefined reference to `WinMain@16'
g77-2 -mno-cygwin breaks:
/usr/lib/mingw/libmingw32.a(main.o)(.text+0x8d):main.c: undefined reference to `WinMain@16'

I'm probably doing something very stupid, which will occur to me 2
seconds after I send this, but could I ask you to wipe out your current
gcc2 installation, reinstall it, and see what happens?

Sorry.  I was slow.  It took me about twenty seconds.

You can disregard this email.
I gather you figured out what was "wrong" with g77-2 in gcc2-2.95.3-8 ?


P.S. Now, my tests are very very simple. Consider them "basic" functionality tests. We still need more "real world" testing before these are ready to go, IMO.

Also, I'm thinking that the files in
/usr/include/g++-3/ (including _G_config.h)
should go into a
package (perhaps along with

usr/lib/mingw/libstdc++.a from mingw's gcc, appropriately '-2' renamed)

Hey, wait a minute -- maybe that's why g77-2 is failing? It's linking against libg2c.a from 3.1? Yep, seems so!


Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]