This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: New setup pre-release - feedback needed

Hi Robert,

> The pre-release snapshot can be found at
> We're coming up on a new release of setup.exe, with a number of user
> interface enhancements to make it more obvious what setup is doing when it
> 'pauses'.
> It *should* be bug free, although there may be a minor bug with
> autodetection of upgrades (we have one report, but no debugging info).

I tried this setup version, but I got some really strange results regarding
the autodetection.

My system was upgraded last time roughly 3 months ago. I always use the
2-step method: Download from Internet; Install from local. I used
for download.

1) Setup did not present me all updates. E.g. packages like cygwin, cygutils
were at "keep" although I knew there were newer versions (I never switched
between Prev/Curr/Exp, only between the View Category/Full).
2) Even when I'd explicitly chosen e.g. cygutils for the new version
(I had still the package was not loaded ... the checkbox in the
binary col was not set. I *assume* any package without a default selection
for the binary column is not selected automatically for an upgrade (possibly
only if the current version is not available as previous version anymore ...
3) Even harded was the upgrade from cygwin 1.3.10.x to 1.3.12-2, since every
time I toggled any other package, the cygwin package was reset to version
1.3.10.x with "keep"
4) I cannot download the gettext package anymore. The explicit selection of
gettext-1.11.2-2 will download it, but it is not available for local
installation toggling the second column (although I got the
gettext-devel-1.11.2-2 package).

The behaviour for the dependencies was equal for "download" and "local
install" mode (except topic 4, since nothing was downloaded).

I tried another download/install loop with the mirror because of gettext. Setup warned me that it found
an older setup.ini, but I used it anyway. I supposed that no package would
be downloaded, except of my (again) exlicitly selected gettext-1.11.2-2. I
was astonished, but setup did not only download gettext-1.11.2-2 again, but
also an older version of expat and _PostInstallLast. From the local
installation I had to chose for these two packages "keep" explicitly,
otherwise the two packages would have been downgraded! And again, the
gettext-1.11.2-2 is not avalable for local installation.


Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]