This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: make problem -- does not terminate on error

Randall Shulz wrote:

Have you tried running the command that fails (in the same way that "make" runs it under the circumstances in question) in a shell and seeing what error status it reports back? Is it indeed reporting a non-zero exit status (in addition to printing an error diagnostic)?
Good idea. I did:

$ c:/Progra~1/AQ430/aq430.exe +s -D__AQCOMPILER__ -DOSMAKE_LIBRARY -DOSLIBRARY_TYPE=OSF -DOSLIBRARY_CONFIG=OSA -I../inc/ -Ic:/Progra~1/AQ430/include/ -link license.c
002 Pumpkin, Inc. and its" "Licensor(s). All Rights Reserved.";
"license.c", line 33: Character string too long (> 510 characters)
1 fatal error
aq430: aq430c error return -1 -- processing terminated
$ echo $?

From what I just read on google groups :-), I believe this is a correct way to obtain aq430.exe's return code in this case. I also tried:

$ rm file.does.not.exist
rm: cannot remove 'file.does.not.exist': No such file or directory
$ echo $?

Just to be sure ...

So, it looks like for whatever reason, aq430.exe returns a 0 in this case in the Cygwin environment, but a proper error code (I presume -1) in mingw. Therefore it's not a make issue, but rather has something to do with the way aq430.exe is interacting with the shell ... Very odd.


Andrew E. Kalman, Ph.D.

Pumpkin, Inc.
home of Salvo, The RTOS that runs in tiny places.(TM)

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]