This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: another cron problem - permission denied

> Which version of cron are you running?

cygcheck says

cron                3.0.1-7

> At least part of the problem is the permission of the files in
> /var/cron.
> 1. Please read /usr/doc/Cygwin/cron.README, in particular:
I have
> >
> >3.0.1-6:
> >--------
> >
> >Add a postinstall script which creates the /var/cron and /var/cron/tabs
> >directories appropriately.
> >
file is there

> >3.0.1-5:
> >--------
> >
> >Crontab now changes group membership to be SYSTEM on the crontab
> >files and sets the permissions to 640.  That should allow cron
> >to work immediately with the crontab files created by crontab.
> >Note that this requires that /etc/group has been created and
> >contains the default SYSTEM entry, gid 18. DON'T CHANGE THAT!
Is there

> 2. You should have a file named '' in the directory
> /etc/postinstall.

is there

> You might try removing your /var/cron directory tree and then running
> that file/script.  If you don't have it, here is a copy

This seems all okay. So I tried to delete the current cygwin installation
(removing the cygwin base dir)
and recogniced, that I can't delete the file in /var/cron because the owner is

I tried to change the access rights and then could delete the tmp files in
/var/cron/tabs, but I'm unable to delete the /var/cron/tabs folder, because I 'm
not allowed to change (1) the owner and (2) am not allowed to change access
rights (allowed only to view the rights )

Any idea how to fix this ?

BTW: It's an NT 4.09 SP6 Workstation


Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]