This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

mysql troubles in cygwin


First, congratulations and praise to the cygwin developers, it is a very
impressive package and one that I'm using to do a lot of work for Bioperl, a
perl-based bioinformatics effort.

Everything I've tried so far in cygwin has worked very well, and the
installs have been straightforward, with the exception of mysql, version
3.23.51. I do the configure with the -prefix option as '/usr/local/mysql' as
recommended, the compile is seamless, the chgrp and chown commands work, the
scripts/mysql_install_db command works, I can start the database
(bin/safe_mysqld &) and I can see it running in Task Manager, but I'm unable
to log in to the database:

/usr/local/mysql>bin/mysql -u root -p
Enter password:
ERROR 2013: Signal 14
020812 11:30:28 mysqld restarted
Lost connection to MySQL server during query

More details:

Windows NT 2000 v. 5
Cygwin 1.3.12

The BOSBORNE.err file says:

020812 11:30:28  mysqld restarted
Warning: One can only use the --user switch if running as root
/usr/local/mysql/libexec/mysqld: ready for connections

You may argue that this is a mysql question, but I'm pretty sure that this
is a problem specific to cygwin, I've been able to do the corresponding
install on Linux, it works. Also I've found no useful information at Has anyone gotten mysql to run on a recent cygwin release? My
gut feeling tells me that this is a configuration or permissions issue, I've
tried all sorts of chmods and chowns and chgrps, nothing has worked,
obviously. I also see the same problem if the bin/mysql executable is setuid

Thank you,

Brian O.

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]