This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Trouble running sshd as NT-Service

what does /var/log/sshd.log say ?
if it has "Bad owner or mode for /var/empty" in it then 
chmod 700 /var/empty
chown -R SYSTEM.SYSTEM /var/empty
(was the only prob i had with setting it up with priv separation, thanks to
all Corinna's hard work ;)

-----Original Message-----
From: Bjoern Kahl AG Resy []
Sent: 23 August 2002 20:45
To: Cygwin Mailing List
Subject: Trouble running sshd as NT-Service



 I can not run sshd as NT-Service under NT4.0 Server.
 Starting the service fails with "NT internal error 2140"


 I am allmost sure, I missed some minor thing, but looking in the
 archive (found one thread about 2140) and trying google did not
 give me a usefull hint. I did the following:

 - NT-4.0 Server, configured as PDC
 - downloaded Setup.exe from, today, Fri 15:45 MET
 - did a download from, full-install expect
 - moved away old installation, and installed in a fresh
   directory. no cygwin service running by that time
 - got a lot of errors from post-install scripts, way to fast
   to read.
 - recreated passwd and group, because post-install missed some
   (all?) of the domain-groups
 - changed group-ownership of all files and directories to an
   other domaingroup (Domän-Benutzer -> own_group). Last one is
   a self-created group. Allmost all files are now owned by
   adminstrator.own_group (544.11002 here)
 - rebooted
 - copied back old sshd-config-files to new /etc
 - run "sshd-host-config"
   selected run by cygrunsrv and enabled privSep. The script
   created a (disabled) user sshd. I used the default CYGWIN
   variable as suggested by the script
 - tried to start sshd via control-panel -> error 2140

 I assumed privileg problems and played a bit around, but to no
 avail. sshd still does not start.
 I tried:
 - enable the sshd user
 - added ".exe" suffix to the sshd executable path in the registry
 - some more things I dont exactly remember
 - I have verified that SYSTEM has full-access to the sshd-binary
   and all directories above it (including the windows drive root
   on which the cygwin-directory in installed)

 the event-log says "execv: 1: operation not permited".

 Please find attached the cygcheck-output and the sshd registry-keys.

 If you need further information, or have any test I should run,
 please tell me.

 Thank you

  Bjoern Kahl

| Dipl.-Phys. Bjoern Kahl +++ AG Embedded Systems and Robotics (RESY) |
| Informatics Faculty +++ Building 48 +++ University of Kaiserslautern|
| phone: +49-631-205-2654 +++ www:   |

Unsubscribe info:
Bug reporting:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]