This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Crash in lynx

On Fri, Jul 18, 2003 at 04:07:08PM +0200, Ronald Landheer-Cieslak wrote:
> When wanting to have a look whether a new pcre was available at 
>, I had a slight case of fat fingers and made lynx crash :|
> (cygcheck output below)
> $ lynx www.pcre.orgf
> *crash*
> Some particularities about my current setup: sh-utils is built here (but I
> don't think that matters), Cygwin is the one I checked out from CVS
> yesterday at 1600 CET (that will probably matter) and aspell is installed 
> (but I don't think that matters). The rest will show up on the cygcheck 
> output.
> Actually, the same thing happens if I just do `lynx', so it's 
> not the fat-fingers part that makes it so..

Hmm, the strace isn't very helpful, sorry.  There's actually no hint what
happens.  It's a function inside Cygwin which crashes but I guess you'll
have to debug that by yourself.

I tried the current lynx 2.8.4-5 in an ssh session, in rxvt and in a
console window, both, the fat-fingered as well as the correct link. 
No crash. 

Then I rebuilt lynx for 64 bit mode (already uploaded to and
tried all of the above again.  No crash.

Then I rebuilt the latest Cygwin from CVS and tried again.  Guess what?
No crash.


Corinna Vinschen                  Please, send mails regarding Cygwin to
Cygwin Developer                      
Red Hat, Inc.

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]