This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

_GETTEXT undefined problem

I'm trying to build a complete application software set (written in C) that
has been provided to my university.  The source (142 MB, comprising about
11,000 files, made of approx 560 supporting libraries and about 10 main
applications) all installed, autoconfigured and built OK straight from the
CD on a Redhat 9 Linux system, but 3 out of the 560 odd support libraries
won't build under Cygwin 1.3.22-1 on a W2KPro SP4 system.

Although I'll confess to being a complete newbie with regard to C
application development, the build failure seems to stem from problems in
the internationalisation support : specifically accessing the supplied
gettext-0.10.35 that is provided and built in the source tree of this
application.  Make errors as follows:

/usr/bin/gcc -L/home/otb/OTB_Intnl_ABCA/lib  -L/usr/X11R6/lib bmap_to_lmap.o
-o bmap_to_lmap
bmap_to_lmap.o(.text+0x186):bmap_to_lmap.c: undefined reference to
bmap_to_lmap.o(.text+0x1cb):bmap_to_lmap.c: undefined reference to
bmap_to_lmap.o(.text+0x279):bmap_to_lmap.c: undefined reference to
bmap_to_lmap.o(.text+0x2ba):bmap_to_lmap.c: undefined reference to
bmap_to_lmap.o(.text+0x461):bmap_to_lmap.c: undefined reference to
bmap_to_lmap.o(.text+0x4d5):bmap_to_lmap.c: more undefined references to
`_gettext' follow
collect2: ld returned 1 exit status
make[2]: *** [bmap_to_lmap] Error 1

It's already been suggested to me (by the developer community of this
specific application set) to try replacing the libintl.a that was built by
the application makefile with a link to the libintl.a supplied as part of
Cygwin itself.  I tried this, which apparently had worked for some
developers having similar problems, but without any success.

Since the exact same source tree does build OK under RH9, I guess this must
presumably be down to some difference in how Cygwin does things or perhaps
to a confusion between the app-supplied gettext and the system-supplied one?

I'd be very grateful for any suggestions/pointers on how to even further
diagnose, nevr mind fix, the problem.

Output from running 'cygcheck -s -v -r' attached as requested.



Jonathan R Searle 
Manager,  SSEL - Simulation & Synthetic Environment Laboratory, 
Engineering Systems Department, Cranfield University, UK 


Attachment: cygcheck.out
Description: Binary data

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]