This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problems with archiver "ar"

Hash: SHA1

According to Frank Illenseer on 10/2/2006 2:51 AM:
>    C:\DATA\myProject\solution1
> so I tried (taking your mount as reference)
>   mount -f -u -t "C:\DATA\myProject\solution1"
> "/cygdrive/c/DATA/myProject/solution1"

Don't mount to /cygdrive/c/DATA/; mount points to a subdirectory of
/cygdrive don't really do any good, because the path resolution does not
look for mount points residing inside /cygdrive.  Instead, mount
c:\data\myproject to a POSIX path (ie. something like /myProject).

> but indeed the directory of interest seems to work in binmode.
> I need the directory in the "surrounding" of the other directories, i.e.
> relative paths are required.

If just one subdirectory needs to be text, relative to others that are
binary, then it may be worth mounting those others as well to preserve
your desired relative hierarchy.

> PS: The problem with "ar" is still there and I think (as Eric pointed
> out) that "ar" is not correctly reading in binmode/textmode. Once I
> solved the mounting problems, I will do some more tests with "ar".

What more needs to be tested?  Until cgf releases a new binutils with an
update to ar that forces binary mode on all archival actions, the current
behavior on textmounts isn't going to change.

- --
Life is short - so eat dessert first!

Eric Blake   
Version: GnuPG v1.4.2.1 (Cygwin)
Comment: Public key at
Comment: Using GnuPG with Mozilla -


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]