This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: 1.5.21-2 CYGWIN1.DLL Invalid Page Fault (in a new thread)

Charles Brockman wrote:
Larry Hall (Cygwin) wrote:
Here's some environment variables that may affect cygwin:
I'd recommend getting rid of this setting. It's incorrect.

That relic is now gone.


Looking to see where common programs can be found, if at all...
Not Found: awk
Not Found: bash
Given what you've installed, the above is not good.  It indicates that the
installation went awry somewhere.  You should try rerunning 'setup.exe' and
see if it just needs to finish installing things.

I ran setup.exe on my local repository. It reported no problems and offered no files for installation.

If not, you may want to
try removing everything and installing again.

I hid the old c:\cygwin directory and did a new, minimal installation, selecting just cygwin and its dependent files. At post-install I received numerous invalid page fault errors identical to the original while bash was attempting to run.

Thinking that my cygwin was corrupted, I deleted the new c:\cygwin directory and
the local copy of cygwin-1.5.21-2.tar.bz2. Then I downloaded a new copy of
cygwin-1.5.21-2.tar.bz2 and the other files that came with it. Another
installation attempt and the same failures.

Then I stepped back to the 'previous' versions offered by the mirror and
downloaded that group of packages.  (Unfortunately, that still includes the
1.5.21-2 version of cygwin but earlier versions of several other packages.) That
installation went okay except for about twelve Error Starting Program windows
reporting: "The BASH.EXE file is linked to missing export
CYGREADLINE6.DLL:rl_variable_value" so the installation was not useable.

In the interest of science I ran setup.exe again, this time only updating
readline6. Setup finished without complaints but the original invalid page fault
error in cygwin1.dll has returned. Cygcheck -c reports all files OK.

The "Looking to see where common programs can be found..." section produced by
cygcheck -s has improved as shown in the attached scheck.txt file.


Should I try anything else?

I'm not sure.  Maybe look around on your system (using the Windows find
utility) to see if there is another cygwin*.dll on your system.  Short of
that or some divine inspiration on my end, I'm out of ideas, at least for
the moment.  I'm not a 98 user or much of a fan. ;-)

-- Larry Hall RFK Partners, Inc. (508) 893-9779 - RFK Office 216 Dalton Rd. (508) 893-9889 - FAX Holliston, MA 01746

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]