This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

command not found2: pwd and other errors

Hi All,

I am no expert with cygwin and unix, though I use cygwin a lot while
developing software. I have been developing for one of my clients on my
local machine and now am trying to replicate my development environment
on one of their machines. Everything seems okay until I try to run a
shell script, which worked just fine on my machine. It is an extremely
basic script launching a java app. Here are the results:


: command not found2: pwd
: No such file or directoryhome/bturner
: No such file or directoryjmdental
: command not found7:
Unable to access jarfile jar/powerpick.jar


Here is the script (this is not the exact original, I tried a couple
things to see if I could figure out what is going on):


echo ${HOME}
cd ${HOME}
cd rjmdental

${JAVA_HOME}/bin/java -jar jar/powerpick.jar


NOTE: the pwd command and the cd commands work fine when at that command line. I
cannot see what could possible be wrong. I don't understand why the
pwd command is not found, nor can I understand why the cd command seems
to drop the leading /.

I had copied my whole project from my machine to the client machine,
after installing cygwin. I did change the .passwd file in /etc so that
I was pointed to the correct directory, I have a different username on
this machine. I also changed other instances of my old user id to my
new user id.

I've tried googling for answers, including this usergroup, but cannot
seem to find anything related to my problems. If any of you have any
ideas, I'd surely appreciate a response!



Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]