This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: sh files

Thanks Eric. Unfortunately, your remedy did not work. As I mentioned in my
original mail, all my .sh files were made under unix. But I tried d2u anyway
(you never know), but I got the same result.

Here is an example of one of my unsophisticated .sh files; it was intended
to clean up after a latex session:
rm *.div *.aux *.log 

when I run the (this was the name I gave to it), I get the 'command
not found' error reply.

Does that help to make you better see my problem?

Eric Blake-1 wrote:
> Hash: SHA1
> According to dubcek on 10/29/2006 12:59 PM:
>>>From the time I started using UNIX, I have made at least a hundred
>> .sh files, all of which ran perfectly on my first version of cygwin. But
>> they don't work on the new version.
> What are the failure symptoms?  Without any further details, my guess is
> that you have CRLF line endings, but a binary mount.  Use the d2u program
> to convert your .sh files to plain LF line endings, and things should
> clear up.
> - --
> Life is short - so eat dessert first!
> Eric Blake   
> Version: GnuPG v1.4.2.1 (Cygwin)
> Comment: Public key at
> Comment: Using GnuPG with Mozilla -
> iD8DBQFFRRuv84KuGfSFAYARAtdiAJ96mdxigxSrCNJGikpv1N/SBiLfvQCaAmRe
> z/b+ZVxXhG7ONhtnyPRrnsI=
> =HRc0
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

View this message in context:
Sent from the Cygwin Users mailing list archive at

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]