This is the mail archive of the gdb-patches@sources.redhat.com mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: [RFA] More completion improvements


On Feb 18, 12:53pm, Fernando Nasser wrote:

> This style for the add_show_from_set() call is everywhere. As we need to
> revise the creation of CLI commands anyway, this will not last long
> enough for us to consider a major cleanup.  It will just go away
> naturally...

Fernando,

I took another look, and I don't see the style that I was objecting to
used *anywhere* with add_show_from_set().  Perhaps, I was not clear
enough in my original message.  What I find (mildly) objectionable is
changing code which looks like this:

    add_show_from_set (add_set_cmd (...), &showlist);

to:

    add_show_from_set ((c = add_set_cmd (...)), &showlist);

Note the addition of an embedded assignment expression.  Instead, if
it becomes necessary to add an assignment, it should be added as a
separate statment, thusly:

    c = add_set_cmd (...);
    add_show_from_set (c, &showlist);

Kevin


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]