This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [RFA] dwarf2_physname


On 09/01/2009 02:26 PM, Tom Tromey wrote:
If this is a hardship for some reason we can discuss it.

I don't have a problem *not* committing it, especially with all the 7.0 talk about. But it will be difficult for me to keep posting patches which refine earlier (uncommitted patches). Well, actually, it's not as much a problem for me as it is for maintainers. Stuff will be really hard to read/diff/try. [I think (TM).]


But it's your (collective) call. Tell me what you'd like me to do, and I'll do it.

Keith>  +/* A vector used during linkage name generation.  */
Keith>  +typedef struct die_info *die_info_p;
Keith>  +DEF_VEC_P (die_info_p);
Keith>  +static VEC(die_info_p) *die_list;

I wonder if a global is really necessary.
I didn't check.

The global is there to avoid having to reallocate the thing every time dwarf2_physname is called. In a large C++ application, that could be MANY MANY MANY times.


So, something must be missing here -- either an explicit initialization
of the vec, or this should use VEC_safe_push.

Yes, there *is* an explicit initialization in _initialize_dwarf2_read, but I did not include it in this revision of the patch, since it would not actually be used *until* I "flipped" the switch. In other words, you would have seen the initialization when the final patch was submitted.


I apologize, I know this is going to be very confusing. Think of this first patch like a "big picture" design overview. Subsequent patches will build on/refine this until everything is ready to go in and be "turned on."

The problem is that the necessary changes are /so/ pervasive that in order to avoid test suite failures, I would have to submit a several thousand line patch which touches dozens of files, and I was hoping to avoid doing that kind of "patch dumping" ('cause I don't like it when that is done).

Again, let me know how you would like me to proceed, and I will happily try to accommodate you. The burden of review is on you (maintainers). I want to do what I can to make it as easy as possible for you.

Keith


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]