This is the mail archive of the
mailing list for the GDB project.
Re: [PATCH 22/348] Fix -Wsahdow warnings
> please condense down your patches if you resend. there's way too many
> little tiny ones that really should be squashed into a single
In my view, if the patches can be checked in independently, then
it is a good thing that they are split. Imagine the situation where
one of these changes is bad, we'd then be able to revert that one
patch, rather than fixing by hand.
> your ChangeLogs are also incorrect. it should not be:
> * bcache.c (expand_hash_table): Fix -Wshadow warnings.
> but rather:
> * bcache.c (expand_hash_table): Rename bcache to cache.
I'm 50/50 on this. I don't mind either way. What do others think?
Is that really that important that we must create boring extra work