This is the mail archive of the gdb-patches@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCHv2 2/2] gdb: Change how frames are selected for 'frame' and 'info frame'.


* Philippe Waroquiers <philippe.waroquiers@skynet.be> [2018-06-05 23:15:16 +0200]:

> On Tue, 2018-06-05 at 19:53 +0100, Andrew Burgess wrote:
> > > If we do need a keyword, how about "frame add"?
> > 
> > Personally, I think 'add' is worse than 'create' - what's the frame
> > being added too?  But I do acknowledge that 'create' is not ideal
> > either.
> > 
> > I wonder if 'new' is better than 'create', maybe implies less "making
> > something in the inferior"?  Or how about, 'for' instead, like this:
> > 
> >   (gdb) frame for STACK-ADDR PC-ADDR
> 
> If nothing is added or created or ...,
> maybe you could also use one of:
>     (gdb) frame interpret STACK-ADDR PC-ADDR
> or
>     (gdb) frame look STACK-ADDR PC-ADDR
> or
>     (gdb) frame view STACK-ADDR PC-ADDR

I like 'view', the docs could read:

    View a frame that is not part of GDB backtrace.  The frame viewed
    has stack address @var{stack-addr}, and optionally, a program
    counter address of @var{pc-addr}.

    This is useful mainly if the chaining of stack frames has been
    damaged by a bug, making it impossible for @value{GDBN} to assign
    numbers properly to all frames.  In addition, this can be useful
    when your program has multiple stacks and switches between them.

Eli, how does this sound?

Thanks,
Andrew


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]