This is the mail archive of the gdb@sourceware.org mailing list for the GDB project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: conditional breakpoint with (char* ) string condition


PAUL GILLIAM <pgilliam@us.ibm.com> writes:
> On Fri, 2006-05-12 at 09:54 -0400, Daniel Jacobowitz wrote:
>> On Fri, May 12, 2006 at 04:49:49PM +0300, Eli Zaretskii wrote:
>> > > Date: Fri, 12 May 2006 08:45:27 -0400
>> > > From: Daniel Jacobowitz <drow@false.org>
>> > > Cc: gdb@sources.redhat.com
>> > > 
>> > > I wonder.  Should we add some common builtin functions to GDB?
>> > > 
>> > >   b gui/R.cpp:190 if $gdb_strcmp (cmd, "train")
>> > 
>> > It would be nice, I think.  `streq' might be a better name, though.
>> 
>> Well, I'd rather have strcmp, but I agree that I botched it - I was
>> going for something with the same semantics as C strcmp :-)
>> 
>
> IMHO, this is something that has been 'missing' from GDB from day 1.
> Building in some common functions into GDB would be a big win.
>
> How about strlen as well?

I'm definitely in favor of $strcmp and $strlen.

Should we establish a convention of starting GDB-provided convenience
variable names with _, to avoid conflicting with script variables?
Thus, $_strcmp and $_strlen?


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]