This is the mail archive of the guile@sourceware.cygnus.com mailing list for the Guile project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

SCM_NINUMP


Hi!

I realized that due to the reordered dispatch sequences almost all
occurrences of SCM_NINUMP have been eliminated.  Thus, I wonder whether we
should deprecate this macro?

More general, shouldn't (as a long term goal) all macros like SCM_NXXXP be
removed?  They don't provide that much convenience (if any), since they
are typically simply defined as
  #define SCM_NXXXP (!SCM_XXXP)

Since I personally find it easier to read
  if (!SCM_INUMP (n))
than
  if (SCM_NINUMP (n))
I'm in favor of such a change, i. e. getting rid of the negating macros.

Moreover, I have often encountered mind twisters like
  if (!SCM_NIMP(...)) some_code;
thus I wonder why people have not done things like this:
  if (!SCM_NIMP(...)) ;
  else {
    some_code;
  }
(I guess it could still be improved :-)

Best regards
Dirk


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]