This is the mail archive of the libc-alpha@sourceware.org mailing list for the glibc project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Cross-rpcgen patch, version 4


> +build-compile-command.c = $(BUILD_CC) $($(basename $(<F))-CFLAGS) \
> +			  $(ALL_BUILD_CFLAGS) $< $(OUTPUT_OPTION)

A variable of this name should include -c, since it's parallel to
compile-command.c.  If it's not going to include the dependency-generation
flags, then it should be called build-compile.c instead, since it's really
parallel to compile.c and not to compile-command.c.

If it's not prohibitively hairy, making it do the automatic dependencies
stuff would be nice.


Thanks,
Roland


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]