This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: resolving file access permissions...

P.B. Dushkin wrote:

hi. so, i have done a good deal of net searching pior to seeking
email advice, i'd appreciate your feedback at this point...

I have recently installed cygwin on W2K using CYGWIN=binmode ntea tty;
It seems that ntsec is infinutely more useful for unix-like file
directories but, from what i gather, it won't be much use to me on at
FAT32 system.

I gather, given my setup, that the "chmod NNN File" command is relatively
useless. When I do attempt this approach, I get "Bad File Descriptor"
returned. Any chmod command returns the same result. I am guessing that
this might be due to the UNIX to DOS mapping features of cygwin but, if
there is a way to make chmod work, i'd love to hear it (I have read
the FAQ and still didn't find a good solution).

I am learning my way around ACLs. The file i am trying to access
is Hello.c. When i type ls -l I get -rw-r--r--. I have tried setfacl to
change these values to something similar to "chmod 777". Everything i type has no effect:

setfacl -m u:Peter Dushkin:rwx Hello.c
setfacl -m u:(null or 544): Hello.c
setfacl -s u:Peter Dushkin:rwx Hello.c
setfacl -s u:(null or 544):rwx Hello.c
setfacl -s u:544
setfacl -m u:544... and so on

The core of my questions are this:

1) am i right to be using ntea given my system 2) am i right that chmod won't work (and what is meant by "bad file descriptor" 3) Should i cange some values in either my passwd or group files that will make setfacl work? 4) If not, could you please describe an exact command that might do the trick... I see in the help file that the convention is: setfacl [-r] (-f ACLFILE | -s acl entries) FILE Is there an *actual* ACL file that I should be referencing in my commands and, if so, where is it located?

You're stuck between a rock and a hard place as they say, assuming you
plan to stick with FAT32 as your file system type (and that you're not
interested in supplying a patch to Cygwin ;-) )  You're right that
'ntsec' only works for NTFS.  Unfortunately, it's been determined that
'ntea' only works for FAT partitions from NT/W2K/XP.  It doesn't work
on FAT32.  This is a bug.


Larry Hall                    
RFK Partners, Inc.                      (508) 893-9779 - RFK Office
838 Washington Street                   (508) 893-9889 - FAX
Holliston, MA 01746

-- Unsubscribe info: Problem reports: Documentation: FAQ:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]