This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

(Fwd) Re: Setup hangs between "create icons" and "postinstall"

OK, the mailer wouldn't accept it with the attachment, too big.  If 
you'd like the file, tell me where to send it and I will.

Will Marsh 

------- Forwarded message follows -------
From:           	Will Marsh <>
Subject:        	Re: Setup hangs between "create icons" and "postinstall" und
Send reply to:
Date sent:      	Fri, 13 Jun 2003 11:29:37 -0600

Thanks, Elfyn.

Yesterday, I tried using both "setup-2.358.exe" and "setup-2.358-
debug-00.exe.gz", accepting the default packages.  I also tried 
a couple different mirror sites, clearing everything out and starting
over atfer each attempt.  With these, I never see the "Create Icons"
screen.  The last thing the install screen shows, with 97% in the top
bar, is: 

No Package

with the status bars below.  I never moves after this, and a couple
times I waited 30 minutes or more before I cancelled it.  When I hit
the "cancel" button at that point, it tells me "Installation
Complete", but when I try to run Bash I get the same error as 

I did get a setup.log.full file.  It all looks normal, no errors. 
Here are the last few lines:

2003/06/12 18:02:29 textutils
2003/06/12 18:02:29 which
2003/06/12 18:02:29 zlib
2003/06/12 18:02:29 _update-info-dir
2003/06/12 18:02:29 running: 
D:\cygwin\bin\sh.exe -c /etc/postinstall/base-
2003/06/12 18:31:31 mbox note: Installation 
2003/06/12 18:31:33 Ending cygwin install

I assume the "Installation complete" line is where I hit "Cancel". 
I'll attach a copy of the file if you want to look at the rest.  

It also creates a "setup.log.postinstallXa67883" that is 0 bytes.

HTH, any insights you could give are welcome.  

Will Marsh

On 12 Jun 2003, at 22:14, Elfyn McBratney wrote:

> On Thu, 12 Jun 2003, Peter S Tillier wrote:
> > Will Marsh wrote:
> > > I downloaded the latest version of Setup (2.340.2.5) and have
> > > tried to install it several times under Win ME 4.90.3000.  It
> > > always hangs at the same point, right after "Create Icons", with
> > > the following message in a DOS window:  "This program has
> > > performed an illegal operation and will be terminated.  Quit all
> > > programs and then restart your computer."  If I click on the
> > > "Details" box, all it gives me is "Fault Location :   C000.0D66"
> > >  
> > >  Restarting windows at this point and trying to run Cygwin gives
> > > the same message with a different "Fault Location
> > >:   C000.7A00"
> > >
> > > At this point, if I check C:\cygwin\etc\postinstall, all the
> > > files have .sh at the end, none have the .done. 
> > > C:\cygwin\var\log doesn't exist.
> > >
> > > I've tried the default install, the ALL install,  and the
> > > default
> > > + a few packages.  Same results for all of them.  I've tried
> > > running setup again over the top, same results.  I've tried
> > > deleting the whole thing (directories, registry entries, Setup)
> > > and starting over, same results.
> > >
> > > Any ideas or other things I should check?
> >
> > I guess you have checked that your Windows ME has all the latest
> > service packs and/or patches applied?  Don't know if this will
> > help, but it may be worth a shot.
> Would you (Will) be able to try a setup debug snapshot? I've had
> some problems using setup.exe on newly installed machines and in all
> cases the debug version has worked.
> See <>.
> Elfyn
> -- 
> Elfyn McBratney (
> Systems Administrator
> /

------- End of forwarded message -------
Will Marsh

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]