This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

top is gone


Today, I came in and found a Kerio firewall warning
that someone from Australia (other side of world)
tried to connect the the sshd process (part of
cygwin).  No problem, just deny access.  Then I
tried to run "top" and the command was not recognized.
That's weird.  xterms don't give me the expected
popup menus when I control-click.  I checked the task
manager, and no weird processes except maybe crypserv
and regsvc, both of which can be disabled according
Black Viper (I'll do that as soon as I figure out how).

But the missing "top" was strange enough that I
wiped out the entire c:\cygwin tree and reinstalled
it from scratch.  Just to be safe.  For some reason,
top is still unrecognized, even after "hash -r".
There is no top in /usr/bin, and nothing in
/usr/local/bin.  There is no top to select in the
cygwin setup table.  There is no top command in
the bash man page.  And there is no other posting
about the missing top command in the mailing list
archive.  A file search for top starting from
c:\cygwin turns up nothing relevant.

What path is top suppose to be in?  Are there any
known reasons why it would just disappear like that?
I just spent the whole night trying to get my
environment back (not finished yet), and I wonder
if it might have been something simple I'm overlooking.

Fred Ma,
Carleton University, Dept. of Electronics
1125 Colonel By Drive, Ottawa, Ontario
Canada, K1S 5B6

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]