This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: ProFTPd usable on WinXP-HE, questionable to me

Is this any help ?

> -----Original Message-----
> From: Soren A. []
> Sent: 23 June 2003 10:14
> To:
> Subject: Re: ProFTPd usable on WinXP-HE, questionable to me
> "Soren A." <> wrote in 
> Xns93A2AC9379A2alsocuteandfluffywor@">news:Xns93A2AC9379A2alsocuteandfluffywor@
> > 
> > Attachment decoded: cygcheck.2003.Jun.22
> > --==_=_====____37794.70672821764D1BD3B9==
> Sheesh. Did Gmane trip me up? There WAS all this text before the 
> attached `cygcheck` output:
> ---------------------------------------------------------------------
> Hello!
> I've been trying to set up ProFTP on a WinXP Home Edition system with
> Cygwin and it isn't working.
> My efforts include reading "README.cygwin" under /usr/doc/proftpd/ and
> making the suggested changes (insofar as I could understand 
> the meanings
> in the document) to /etc/proftpd.conf.
> I understand that the ftpd has to have privs like "SYSTEM" and that
> looking at past List messages, Jason Tischler says "run it as
> LocalSystem" user. I don't know what OS Jason is talking 
> about as there
> is no such user "LocalSystem" on WinXP (yet XP is decended from NT).
> So in the /etc/proftpd.conf file I have lines like:
>   User      SYSTEM
>   Group     Administrators
> but when I try to run proftpd, it refuses to start because it won't
> change user context. The user I run Cygwin as apparently doesn't have
> sufficient perms to change user context like this. I don't know how to
> add such rights to the account: the user IS (*IS* *IS* *IS*) an
> "Administrator" on the local system (was created that way).
> Can anyone loan me a clue about what can be done to fix this, 
> i.e. give
> my user account sufficient perms to run proftpd as "SYSTEM"?
> The user management interface on WinXP that is where I'd look for
> changes like those available under NT4, for changes various 
> user rights,
> just isn't there, AFAICT.
> Alternatively, is there anything that can be done to convince 
> ProFTPd to
> run as another user?
> I've tried (since the original broken posting) to start ProFTPd as 
> another user via "runas", but it won't start the service that 
> way (I ran 
> the config script and then runas "net start proftpd"). The service 
> appears in the Admin tool under "services" but trying to restart it 
> always fails (i.e. it is always in a "stopped" state). Also I 
> cannot get 
> a commandline to "runas" that will work from bash, my only 
> success has 
> been from a CMD.exe prompt.
> How are people doing this?
> Sorry to be bitchy about it and thanks to all those who have 
> contributed
> to this port.
>    Soren A.
> PS. I am posting from Gmane.
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]