This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Apache mod_ssl fork problem

Hi folks,

I'm having problems connecting to Apache with mod_ssl (all latest 
versions) -- the output of error_log looks like this:

D:\cygwin\usr\sbin\httpd.exe: *** unable to remap D:\cygwin\bin\cygssl.dll 
to same address as parent(0xB20000) != 0xB30000
65154432 [main] httpd 2956 sync_with_child: child 3048(0x684) died before 
initialization with status code 0x1
65200803 [main] httpd 2956 sync_with_child: *** child state child loading 
[Sun Jul  6 16:17:14 2003] [error] (11)Resource temporarily unavailable: 
fork: Unable to fork new process

over and over. I've tried rebasing everything as discussed in

but with no joy, cygssl.dll still doesn't want to remap. I made sure I had 
nothing but bash running when I did the rebase, closed all services etc...

Any suggestions gratefully received. Since this is for a low-volume 
private server, is there any way to kick off a pool of httpd processes in 
advance rather than forking to answer each request -- maybe with inetd? 
Would that help? Haven't used apache (or unix web servers at all) for ages 
so I'm a bit out of practice.

cygcheck -svr output attached. Thanks in advance!


Attachment: cygcheck-svr.fourier
Description: Text document

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]