This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: Can't get ssh to forward X packets

Thanks for the reply Todd.  Here's what I found:

Before changing anything:
- There was still no $DISPLAY set on the remote host after logging in.  No
change in behavior, X still not forwarding.

After setting a local DISPLAY in my Cygwin ennvironment, I then tried the
follwoing, and it worked, but I did get an xauth data warning:
jnokes@D-SJC-JNOKES ~
$ ssh -X jnokes@row-cm
Warning: No xauth data; using fake authentication data for X11 forwarding.
[jnokes@row-cm jnokes]$ echo $DISPLAY
[jnokes@row-cm jnokes]$
- I ran a test with xeyes and it worked fine.

Thanks for the solution.  I'm now intrigued as to why I needed this, never
have in the past, and it alwyas just worked fine.  And what is SecureCRT doing
"under-the-hood" to make it work without any visible warnings that Cygwin ssh
is not doing?

Thanks again for the help.
- Jeff

--- Todd Bowden <> wrote:
> The problem is on the client side.
> Before you ssh to your other systems export DISPLAY=localhost:0
> Than try and ssh into Linux systems.
> Test:
> 1.  Before changing anything ssh into Linux system.  What does $DISPLAY
> say?
> 2.  After changing display on client side, What does $DISPLAY say?
> Todd C. Bowden 
> HP Certified 
> AtosOrigin 
> 5000 S. Bowen 
> Arlington, TX 76017 
> Office: 817-264-8211
> E-mail:
> -----Original Message-----
> From: Jeff Nokes [] 
> Sent: Friday, July 11, 2003 2:41 PM
> To:
> Subject: Can't get ssh to forward X packets
> Hi,
> My name is Jeff.  I recently started a new job that gave me a Win2K box
> to ssh into the various unix environments to do my work.  The box came
> with SecureCRT on it, and it works fine.  I prefer to use the cygwin
> environment so I set it up on my workstation, and it seems to work fine
> as well, except for two issues, one of which is the question of this
> posting.
> Whenever I ssh into my dev linux boxes, wishing to have X packets
> forwarded back to my local Xserver on my workstation, it doesn't seem to
> be working through ssh on Cygwin.  It does, however, work with
> SecureCRT.  I just set up Cygwin in June, so all the packages are
> up-2-date.  And I've been using it for a long time at other jobs, and at
> home, and the X forwarding via ssh always works, but not this time.
> I've even tried re-installing the ssh package, but no changes.  When
> looking at the verbose output, no mention of X forwarding at all.  I
> know I'm doing it correctly:
>    ssh -X username@host
> ... and I do log in successfully, but there's never a $DISPLAY variable
> set on the remote host, as there should be.  When I check $DISPLAY when
> logging in with SecureCRT, I can see it just fine, and X forwards
> perfectly.  So, the OpenSSH server is not the issue.  I've even tried
> setting my ~/.ssh/config file to have 'ForwardX11 yes', still nothing.
> I've tried it using interactive and passive logins, etc., still no
> change.
> The older versions of Cygwin I've ran in the past always forwarded X
> seamlessly, not sure why the most recent install won't.  Anyone have any
> ideas?
> Thanks in advance,
> - Jeff
> --
> Unsubscribe info:
> Problem reports:
> Documentation:
> FAQ:         

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]