This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Apache with mod_proxy as caching proxy randomly fails

Elfyn McBratney wrote:

> I assume your using 1.3.24-5? There are known problems in the proxy code and
> wasn't stable "stable" until 1.3.2{5,6}. You might try a newer version...or
> there's always squid. :-)

Hmmm.... Well, I just got .27 to compile.  I hadn't before, but after
screwing with the .24-5 package I knew what to do this time:

LIBS=-lgdbm_compat ./configure --with-layout=Cygwin \
             --with-port=80 --enable-module=most \
make install
mv /lib/apache/libhttpd.* /bin

Fortunately, I don't need mod_ssl so I didn't need to bother trying to
graft in EAPI.

This works, but I first had to remove all vestages of the .24 install,
because the unpatched .27 source makes different filenames (http.exe ->
httpd, cyghttpd.dll -> libhttpd.dll, etc.)  I think that was what was
tripping me up previously when I tried this.

But I still get "(13)Permission denied: proxy: error linking cache file"
errors when I force a reload (Ctrl-F5 in IE, Shift-F5 in Moz/Phoenix.) 
Interestingly, IE gives a broken image whereas Phoenix doesn't -- it
displays the image even though the request returned 503.  (I know this
from watching my Privoxy logs, which sits in the chain inbetween browser
and apache.)

So, still stumped.  It seems to have something to do with the "Pragma:
No-Cache" header that the browser sends, or at least I think that's it
(apache log lists it as "pragma_req=no-cache".)


Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]