This is the mail archive of the mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Inetd question


I installed the latest cygwin and inetd-1.3.23 on my W2K PC to my account only recently. Initially after installation, I got id unknown error. But I fixed it by checking the mailing list and changed my login ID in /etc/passwd file to the it said unknown then I could run bash with no problem. 

However, when I tried to make inetd working so that I could telnet to this PC, and encountered the following problems. 

1) When I setup inetd running as a service using local system account, it started with no error but when I telnet to it, I got "Connection refused" error. I ran "ps -ef|grep inetd", UID showed up as 400 not SYSTEM. (SYSTEM is using UID 18). 

2) My account is a domain account but it is part of local admin group, so I tried to start inetd service using my account. This time after the service started successfully, I could get login prompt, however whatever password I put in, I always got "Login incorrect" error.

I tried recreating /etc/passwd, /etc/group files which was created automatically by the installation, checking /etc/inetd.conf which has telnet starting as root there. But I still got the same problem. I didn't find any helpful log in the event log either. 

Anyone experienced the similar problem before?

BTW, I didn't find syslogd on my cygwin installation. Which package is it in?

Thank you very much for your help!

Xiaoqin Qiu

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]