This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

performance issue with sshd and cygrunsrv


I recently installed cygwin on a new windows 2003 server box, and am experiencing 100% CPU utilization for several seconds (approx 7) when running many commands via ssh connection *to* that box -- even simple commands like "ls -l", "find", that usually return immediately.

What's more interesting is when I run sshd in a command window (either with -d or not) on the server, instead of via service control manager/cygrunsrv, the problem goes away.  I've tried reverting back to the previous cygrunsrv version (1.18), with no change in behavior.  I've also experimented with various settings in the sshd service (ntsec, etc).

I also suspected that it might only involve commands that interact heavily with the filesystem, but even trying to run "vi" with a small file or no file at all produces the same result.

I saw in the list archives some suggestion about anti-virus/firewall software causing problems when forking processes, but i don't have any installed on this machine at the moment. 

Any thoughts on where I should turn next to troubleshoot?

I've attached 'cygcheck -s -v -r' output.


Attachment: cygcheck.out
Description: Text document

Unsubscribe info:
Problem reports:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]