This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

bash.exe.stackdump generated using cygwin 1.7.15

'm experiencing this issue when I run this simple testcase:

just run the command 

c:\cygwin\bin\bash.exe --login -c "/bin/mkpasswd -l > /etc/passwd"

it produces: 


looked for bash.exe.stackdump

here is the cygcheck.out producted by
cygcheck -s -v -r > cygcheck.out 

The problem does not occur if:
1) I run mkpasswd from inside a cygwin
2) if I run c:\cygwin\bin\bash.exe --login -c "/bin/mkpasswd -l > 
  using a cygwin 1.5.e

I recreated the problem in 2 different xp boxes.  But it was also 
recreated in a Windows 7 and a Windows 2008 R2.

As the temporary workaround  looks to be only to install 1.5 through 
setup-legacy.exe I would strongly 
recomned you don't remove the 1.5 from cygwin site until you don't find a 
solution for 1.7. 

Thanks in advance for your help.
I'm available to run any debug module in the environment where the failure 
IBM Italia S.p.A.
Sede Legale: Circonvallazione Idroscalo - 20090 Segrate (MI) 
Cap. Soc. euro 347.256.998,80
C. F. e Reg. Imprese MI 01442240030 - Partita IVA 10914660153
Società con unico azionista
Società soggetta all?attività di direzione e coordinamento di 
International Business Machines Corporation

(Salvo che sia diversamente indicato sopra / Unless stated otherwise 

Attachment: output.txt
Description: Text document

Attachment: bash.exe.stackdump
Description: Binary data

Attachment: cygcheck.out
Description: Binary data

Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]