This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Mintty Log Off problem (now 1.7.16s)

On 29/05/2012 2:27 PM, Andy Koppe wrote:
On 29 May 2012 13:57, Ryan Johnson wrote:
On 28/05/2012 1:32 PM, Harry G McGavran Jr wrote:

On 02/18/12 11:28, Harry G McGavran Jr wrote:
I've found a little more information -- this problem goes away
if I change my default shell to dash.  Seems tcsh is involved somehow.
It comes back when I change my default shell back to tcsh.
Going back to tcsh 6.18.00-2 does not help.

Given the deathly silence to my request below, I must be the only
one experiencing this, but it happens on both of my machines.


On 02/15/12 10:43, Harry G McGavran Jr wrote:
With Cygwin 1.7.10(0.259/5/3) upon logging off Windows XP SP3
I get a pop-up window "End Program - C:\cygwin\bin\mintty.exe"
with a "End Now" and "Cancel" button every time I log off
Windows and I have somewhere in that Windows session run
the Mintty shortcut which has "C:\cygwin\bin\mintty -u -"
in it and my default shell is tcsh. This never happened
with previous Cygwin releases. What's even more interesting
is that in all cases I exit all my programs before logging
off, including the mintty window. I've even tried hitting
the "Cancel" button and then looking for a process named
mintty or "Terminal" (since that's what mintty's description
is and that is used by some process tools) with both Process Explorer
and Task Manager, but I can find no such process -- and then
when I try to log off again not having found such a process
the pop-up comes back and I can't log off until I hit
"End Now".

Since I haven't seen any reports of this on this list, I must
be about the only one this is happening to. Any clues as to
what I can do to find out what Windows is actually failing to stop
when I try to log off having run mintty beforehand?
I'm puzzled why others aren't seeing this or aren't reporting it,
but this problem seems to be back with 1.7.15 and I've now tried
the latest snapshot (May 25) and it's back there too. It occurred
with 1.7.10 and then got fixed, but now it seems to be back.
I routinely encounter mintty windows that don't close after I exit the login
shell they run (even though they contain no visible child processes), but
they can still be closed using the big red "X" in the corner...
Mintty closes when it gets an EOF from the underlying pseudo terminal
device. This happens when there are no more processes connected to it.
The Cygwin console behaves similarly, but other terminal emulators do
not: they close once the direct child process exits no matter whether
other processes are still connected.

Backgrounding a process with '&' or nohupping it doesn't break that
connection, but invoking it through the 'setsid' utility from the
util-linux package does.
That's about what I figured, which is why I'd never worried before. Although I will say I've sometimes had trouble figuring out what cygwin process might be keeping the mintty alive...


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]