This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Mintty Log Off problem (now 1.7.16s)

On 30/05/2012 11:52 AM, Corinna Vinschen wrote:
On May 29 12:41, Harry G McGavran Jr wrote:

On 05/29/12 12:31, Andy Koppe wrote:
On 29 May 2012 17:17, Harry G McGavran Jr wrote:
Ryan Johnson wrote:
I routinely encounter mintty windows that don't close after
I exit the login shell they run (even though they contain no
visible child processes), but they can still be closed using
the big red "X" in the corner... your problem sounds like
something more sinister.


There is never an "X" to deal with here.  One never know there is
a problem until he does start->Log Off to log out of windows.

I can normally close any/all mintty windows and then with various
process explorers try to find a mintty process and never find any.
Then when I log out of Windows, Windows claims it has to close
mintty.exe.  This was fixed once in a snapshot of 1.7.10, but
has since returned with 1.7.15.  In this incarnation it seems to
occur whenever I've run a Cygwin X app from a mintty window.
If I've signed on in Windows and never run a Cygwin X app it
generally doesn't happen, but I can't be sure it never happens.
Every time I've run a Cygwin X app though I can expect to see
it after closing (apparently normally) all mintty windows and
then log off of Windows.
Do I understand you correctly that you no longer have any mintty
windows open when this happens? That's puzzling indeed. Have you
looked at ye olde Big List Of Dodgy Applications?

Yes, your understanding is correct.  My bloda spectrum hasn't
changed since 1.7.10 and is pretty well in hand.  When the problem first
appeared in 1.7.10 and I posted about it, a few days later I got a
suggestion to try the latest 1.7.11s snapshot and see if that fixed it.
  It did, I haven't had the problem since until 1.7.15 and 1.7.16s.

This isn't a show stopper, especially since in this incantation it
doesn't happen all the time, however something isn't quite right...
Interesting the Cygwin X apps aggravate the problem.
Can you try to find out which snapshot introduced the problem?
Perhaps figuring out which snapshot between 1.7.10 and 1.7.11 fixed it would be faster? It sounds like he didn't go very long between 10 and [some] 11s. Not sure it would be as enlightening, though, especially if it's one of these cases where some undefined behavior just happens to do less-horrible things than usual for some reason...


-- Problem reports: FAQ: Documentation: Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]