This is the mail archive of the cygwin mailing list for the Cygwin project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: AW: emacs-w32 24.5.1: Crashes with --daemon and in "About Emacs"

On 5/17/2015 3:44 AM, Martin Anantharaman wrote:

thanks for your quick reply. Regarding the problem with emacs --daemon I
should have given the following background:
1) The commands in my listing (it was actually an attached text-file - which
automagically got inlined into the posting) need to be executed in that
sequence, i.e. emacs --daemon needs to be executed before executing

Yes, I understood that. And, as I said, I couldn't reproduce the problem. The rest of my comment came from an effort to understand where your error message came from.

2) I use the setting (server-use-tcp t) in my .emacs init-file to switch

server-use-tcp is a variable, not a function, so (server-use-tcp t) is not valid elisp. Do you mean you customized the variable server-use-tcp? This would yield

 '(server-use-tcp t)

from the default socket connection-method to TCP - which allows the official
emacsclient (which cannot use local sockets due to MinGW limitations) to
connect as well. On the other hand emacsclient still seems to default to the
socket-connection, so it gives an error-message "emacsclient: can't find

The server still creates a socket, even if it's using TCP, so this doesn't explain why emacsclient can't find the socket.

socket; have you started the server? ..." - but then connect via TCP anyway.
So without this setting (the default) that particular error-message would
not appear.

Can you re-produce the error now?

No, I customized server-use-tcp to t, and I still can't reproduce the problem. Is there something else in your .emacs that could be causing this? Have you tried starting the daemon with 'emacs --daemon -Q' to test this?

Regarding the crash in About Emacs on the second machine I did a clean
re-install but get the same error - so it could be specific to the Windows
XP (yes, I am ashamed to admit it) configuration on that machine. How could
I go about analyzing this, maybe using the stackdump and/or debuginfo?

If you've installed the emacs-debuginfo package, you could try running emacs under gdb. And you should run 'emacs -Q' to make sure the problem isn't triggered by something in your init files.


Problem reports:
Unsubscribe info:

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]